aboutsummaryrefslogtreecommitdiff
path: root/nixos/.flake/home/programs/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/.flake/home/programs/core.nix')
-rw-r--r--nixos/.flake/home/programs/core.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixos/.flake/home/programs/core.nix b/nixos/.flake/home/programs/core.nix
new file mode 100644
index 0000000..1477274
--- /dev/null
+++ b/nixos/.flake/home/programs/core.nix
@@ -0,0 +1,31 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./fastfetch.nix
+ ./foot.nix
+ ./git.nix
+ ./hyprlock.nix
+ ./ncmpcpp.nix
+ ./ssh.nix
+ ./waybar.nix
+ ./zsh.nix
+ ];
+
+ home.packages = with pkgs; [
+ discord # not FOSS
+ emacs # TODO
+ fuzzel # TODO
+ htop
+ hyfetch
+ hyprshot
+ mpc-cli
+ networkmanagerapplet
+ obs-studio
+ pavucontrol
+ prismlauncher # minecraft
+ python3
+ swaybg # TODO
+ texliveFull
+ ];
+}