aboutsummaryrefslogtreecommitdiff
path: root/nixos/.flake/system/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/.flake/system/core.nix')
-rw-r--r--nixos/.flake/system/core.nix138
1 files changed, 9 insertions, 129 deletions
diff --git a/nixos/.flake/system/core.nix b/nixos/.flake/system/core.nix
index 3747531..b15a520 100644
--- a/nixos/.flake/system/core.nix
+++ b/nixos/.flake/system/core.nix
@@ -5,136 +5,16 @@
{ config, lib, pkgs, ... }:
{
- imports =
- [ # Include the results of the hardware scan.
- ./hardware-configuration.nix
- ];
-
- nix.settings.experimental-features = [ "nix-command" "flakes" ];
- nixpkgs.config.allowUnfree = true;
-
- # Use the systemd-boot EFI boot loader.
- boot.loader.systemd-boot.enable = true;
- boot.loader.efi.canTouchEfiVariables = true;
-
- networking.hostName = "nixos"; # Define your hostname.
- networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
- hardware.bluetooth.enable = true;
- hardware.bluetooth.powerOnBoot = true;
- services.blueman.enable = true;
-
- security.pam.services.hyprlock = {};
-
- services.flatpak.enable = true;
- xdg.portal.enable = true;
-
- # Set your time zone.
- time.timeZone = "America/Winnipeg";
-
- # Select internationalisation properties.
- i18n.defaultLocale = "en_CA.UTF-8";
-
- # Enable the X11 windowing system.
- services.xserver.enable = true;
- services.greetd = {
- enable = true;
- settings = {
- default_session = {
- command = "${pkgs.greetd.tuigreet}/bin/tuigreet --time --remember --remember-session --sessions ${pkgs.hyprland}/share/wayland-sessions --cmd \"dbus-run-session Hyprland\"";
- user = "greeter";
- };
- };
- };
- systemd.services.greetd.serviceConfig = {
- Type = "idle";
- StandardInput = "tty";
- StanardOutput = "tty";
- StandardError = "journal";
- TTYReset = true;
- TTYVHangup = true;
- TTYVTDisallocate = true;
- };
-
- programs.hyprland.enable = true;
-
- # Configure keymap in X11
- services.xserver.xkb.layout = "us";
-
- # Enable CUPS to print documents.
- services.printing.enable = true;
-
- # Enable sound.
- services.pipewire = {
- enable = true;
- pulse.enable = true;
- };
-
- # Define a user account. Don't forget to set a password with ‘passwd’.
- users.users.jane = {
- shell = pkgs.zsh;
- isNormalUser = true;
- extraGroups = [ "networkmanager" "wheel" ]; # Enable ‘sudo’ for the user.
- packages = with pkgs; [
- firefox
- tree
- ];
- };
- programs.zsh.enable = true;
-
- # List packages installed in system profile. To search, run:
- environment.systemPackages = with pkgs; [
- greetd.tuigreet
- kitty
- dolphin
- git
- neovim
- wget
+ imports = [
+ ./boot.nix
+ ./desktop.nix
+ ./hardware-configuration.nix
+ ./locale.nix
+ ./network.nix
+ ./users.nix
];
- environment.variables.EDITOR = "vim";
- environment.pathsToLink = [ "/share/zsh" ];
- environment.sessionVariables.NIXOS_OZONE_WL = "1";
-
- # Some programs need SUID wrappers, can be configured further or are
- # started in user sessions.
- # programs.mtr.enable = true;
- programs.gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
- };
- # List services that you want to enable:
-
- # Enable the OpenSSH daemon.
- services.openssh.enable = true;
-
- # Open ports in the firewall.
- # networking.firewall.allowedTCPPorts = [ ... ];
- # networking.firewall.allowedUDPPorts = [ ... ];
- # Or disable the firewall altogether.
- # networking.firewall.enable = false;
-
- # Copy the NixOS configuration file and link it from the resulting system
- # (/run/current-system/configuration.nix). This is useful in case you
- # accidentally delete configuration.nix.
- # system.copySystemConfiguration = true;
-
- # This option defines the first version of NixOS you have installed on this particular machine,
- # and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
- #
- # Most users should NEVER change this value after the initial install, for any reason,
- # even if you've upgraded your system to a new NixOS release.
- #
- # This value does NOT affect the Nixpkgs version your packages and OS are pulled from,
- # so changing it will NOT upgrade your system - see https://nixos.org/manual/nixos/stable/#sec-upgrading for how
- # to actually do that.
- #
- # This value being lower than the current NixOS release does NOT mean your system is
- # out of date, out of support, or vulnerable.
- #
- # Do NOT change this value unless you have manually inspected all the changes it would make to your configuration,
- # and migrated your data accordingly.
- #
- # For more information, see `man configuration.nix` or https://nixos.org/manual/nixos/stable/options#opt-system.stateVersion .
- system.stateVersion = "24.05"; # Did you read the comment?
+ nix.settings.experimental-features = [ "nix-command" "flakes" ];
+ system.stateVersion = "24.05";
}