aboutsummaryrefslogtreecommitdiff
path: root/nixos/.flake/home/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/.flake/home/core.nix')
-rw-r--r--nixos/.flake/home/core.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nixos/.flake/home/core.nix b/nixos/.flake/home/core.nix
new file mode 100644
index 0000000..cfba834
--- /dev/null
+++ b/nixos/.flake/home/core.nix
@@ -0,0 +1,17 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ./cursor.nix
+ ./fonts.nix
+ ./hyprland.nix
+ ./programs/core.nix
+ ./services/core.nix
+ ];
+
+ home.username = "jane";
+ home.homeDirectory = "/home/jane";
+
+ home.stateVersion = "24.05";
+ programs.home-manager.enable = true;
+}