aboutsummaryrefslogtreecommitdiff
path: root/nixos/.flake/system/hardware-configuration.nix
diff options
context:
space:
mode:
authorjjanzen <jjanzen@jjanzen.ca>2025-03-05 22:17:31 -0600
committerjjanzen <jjanzen@jjanzen.ca>2025-03-05 22:17:31 -0600
commite6edbad14d8255743c7b259a1985db5fb5bd4e91 (patch)
treeab535ebf7942b3935b8ec35158291c09226faf73 /nixos/.flake/system/hardware-configuration.nix
parentc1f8c535d59658dd29d199c62326b9436a489ecf (diff)
system changes
Diffstat (limited to 'nixos/.flake/system/hardware-configuration.nix')
-rw-r--r--nixos/.flake/system/hardware-configuration.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/nixos/.flake/system/hardware-configuration.nix b/nixos/.flake/system/hardware-configuration.nix
deleted file mode 100644
index 74ef301..0000000
--- a/nixos/.flake/system/hardware-configuration.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-# Do not modify this file! It was generated by ‘nixos-generate-config’
-# and may be overwritten by future invocations. Please make changes
-# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
-
-{
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
-
- boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
- boot.initrd.kernelModules = [ ];
- boot.kernelModules = [ "kvm-amd" ];
- boot.extraModulePackages = [ ];
-
- fileSystems."/" =
- { device = "/dev/disk/by-uuid/1cf884d2-8691-4122-85e2-a4edd2d1609f";
- fsType = "ext4";
- };
-
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/ABCB-FAEC";
- fsType = "vfat";
- options = [ "fmask=0077" "dmask=0077" ];
- };
-
- swapDevices =
- [ { device = "/dev/disk/by-uuid/675d8161-49c5-4348-9da5-4a7c8ada700f"; }
- ];
-
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp10s0.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlp9s0.useDHCP = lib.mkDefault true;
-
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-}